const regex = /(\d+[A-C]?)-(\d+[A-C]?)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+[A-C]?)-(\\d+[A-C]?)', 'gim')
const str = `137 9/F 135-138A KING STREET TOR
137 9/F 135-138 KING STREET TOR
137 9/F 135A-138A KING STREET TOR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}