$re = '/(\d+[A-C]?)-(\d+[A-C]?)/im';
$str = '137 9/F 135-138A KING STREET TOR
137 9/F 135-138 KING STREET TOR
137 9/F 135A-138A KING STREET TOR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);