import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((0?[1-9]|1[0-2])h)?(([1-5]?[0-9])m)?([1-5]?[0-9]s)?$";
final String string = "1h10m10s\n"
+ "10m10s\n"
+ "10s\n"
+ "123\n"
+ "h\n"
+ "10s1h\n"
+ "5m5s";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}