re = /^((0?[1-9]|1[0-2])h)?(([1-5]?[0-9])m)?([1-5]?[0-9]s)?$/m
str = '1h10m10s
10m10s
10s
123
h
10s1h
5m5s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end