const regex = /^((0?[1-9]|1[0-2])h)?(([1-5]?[0-9])m)?([1-5]?[0-9]s)?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0?[1-9]|1[0-2])h)?(([1-5]?[0-9])m)?([1-5]?[0-9]s)?$', 'mg')
const str = `1h10m10s
10m10s
10s
123
h
10s1h
5m5s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}