use strict;
my $str = '1h10m10s
10m10s
10s
123
h
10s1h
5m5s';
my $regex = qr/^((0?[1-9]|1[0-2])h)?(([1-5]?[0-9])m)?([1-5]?[0-9]s)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}