import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<path>[^?]*)(?:\\?.*)?(?P<p1>param1\\=[^&]*)+(?:\\&.*)?(?P<p2>param3\\=[^&]*)+$";
final String string = "https://www.domain.com/xyz/?param1=123¶m2=456¶m3=789\n"
+ "https://www.domain.com/xyz/?param3=123¶m2=456¶m1=789\n"
+ "https://www.domain.com/xyz/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}