$re = '/^(?P<path>[^?]*)(?:\?.*)?(?P<p1>param1\=[^&]*)+(?:\&.*)?(?P<p2>param3\=[^&]*)+$/m';
$str = 'https://www.domain.com/xyz/?param1=123¶m2=456¶m3=789
https://www.domain.com/xyz/?param3=123¶m2=456¶m1=789
https://www.domain.com/xyz/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);