import Foundation
let pattern = #"^(?P<path>[^?]*)(?:\?.*)?(?P<p1>param1\=[^&]*)+(?:\&.*)?(?P<p2>param3\=[^&]*)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.domain.com/xyz/?param1=123¶m2=456¶m3=789
https://www.domain.com/xyz/?param3=123¶m2=456¶m1=789
https://www.domain.com/xyz/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)