# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<path>[^?]*)(?:\?.*)?(?P<p1>param1\=[^&]*)+(?:\&.*)?(?P<p2>param3\=[^&]*)+$"
test_str = ("https://www.domain.com/xyz/?param1=123¶m2=456¶m3=789\n"
"https://www.domain.com/xyz/?param3=123¶m2=456¶m1=789\n"
"https://www.domain.com/xyz/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.