using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:\d,?){1,10}(?:\.\d{2})?$)[0-9]{1,3}(?:,[0-9]{3})*(?:\.[0-9]+)?$";
string input = @"I want to make sure that the input is no more than 10 digits before the decimals point so it will match DECIMAL(12,2).
I already tried :
^(?=.{0,13}$)[0-9]{1,3}(,[0-9]{3})*(\.[0-9]+)?$
But it counts the digits after decimals too, so what I want to match is:
1,111,111,111.00
so it will keep matching with or without the decimals, what I tried only can match with:
1,111,111,111
111,111,111.00
1,111,111,111,1.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}