import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\d,?){1,10}(?:\\.\\d{2})?$)[0-9]{1,3}(?:,[0-9]{3})*(?:\\.[0-9]+)?$";
final String string = "I want to make sure that the input is no more than 10 digits before the decimals point so it will match DECIMAL(12,2).\n\n"
+ "I already tried :\n\n"
+ "^(?=.{0,13}$)[0-9]{1,3}(,[0-9]{3})*(\\.[0-9]+)?$\n"
+ "But it counts the digits after decimals too, so what I want to match is:\n\n"
+ "1,111,111,111.00\n\n"
+ "so it will keep matching with or without the decimals, what I tried only can match with:\n\n"
+ "1,111,111,111\n\n"
+ "111,111,111.00\n\n"
+ "1,111,111,111,1.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}