re = /^(?=(?:\d,?){1,10}(?:\.\d{2})?$)[0-9]{1,3}(?:,[0-9]{3})*(?:\.[0-9]+)?$/m
str = 'I want to make sure that the input is no more than 10 digits before the decimals point so it will match DECIMAL(12,2).
I already tried :
^(?=.{0,13}$)[0-9]{1,3}(,[0-9]{3})*(\\.[0-9]+)?$
But it counts the digits after decimals too, so what I want to match is:
1,111,111,111.00
so it will keep matching with or without the decimals, what I tried only can match with:
1,111,111,111
111,111,111.00
1,111,111,111,1.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end