import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\s+[^>]*\\bsrc=\"[^\"]*\\/signature\\.gif[^\\>]*\\>";
final String string = "<img src=\"http://example.com/someimage1.jpeg\">\n"
+ "<img src=\"http://example.com/someimage2.jpeg\">\n"
+ "<img src=\"http://test.mydomain.com/project433q325/track/Images/signature.gif\">\n"
+ "<img src=\"http://example.com/someimage4.jpeg\">\n"
+ "<img style=\"OVERFLOW: hidden; WIDTH: 0px; MAX-HEIGHT: 0px\" alt=\"\" src=\"http://test.mydomain.com/project433q325/track/Images/signature.gif?id=446&etc=1586624376\">\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}