// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<img\s+[^>]*\bsrc="[^"]*\/signature\.gif[^\>]*\>"#).unwrap();
let string = "<img src=\"http://example.com/someimage1.jpeg\">
<img src=\"http://example.com/someimage2.jpeg\">
<img src=\"http://test.mydomain.com/project433q325/track/Images/signature.gif\">
<img src=\"http://example.com/someimage4.jpeg\">
<img style=\"OVERFLOW: hidden; WIDTH: 0px; MAX-HEIGHT: 0px\" alt=\"\" src=\"http://test.mydomain.com/project433q325/track/Images/signature.gif?id=446&etc=1586624376\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}