import re
regex = re.compile(r"<img\s+[^>]*\bsrc=\"[^\"]*\/signature\.gif[^\>]*\>", flags=re.MULTILINE)
test_str = ("<img src=\"http://example.com/someimage1.jpeg\">\n"
"<img src=\"http://example.com/someimage2.jpeg\">\n"
"<img src=\"http://test.mydomain.com/project433q325/track/Images/signature.gif\">\n"
"<img src=\"http://example.com/someimage4.jpeg\">\n"
"<img style=\"OVERFLOW: hidden; WIDTH: 0px; MAX-HEIGHT: 0px\" alt=\"\" src=\"http://test.mydomain.com/project433q325/track/Images/signature.gif?id=446&etc=1586624376\">\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")