re = /<img\s+[^>]*\bsrc="[^"]*\/signature\.gif[^\>]*\>/m
str = '<img src="http://example.com/someimage1.jpeg">
<img src="http://example.com/someimage2.jpeg">
<img src="http://test.mydomain.com/project433q325/track/Images/signature.gif">
<img src="http://example.com/someimage4.jpeg">
<img style="OVERFLOW: hidden; WIDTH: 0px; MAX-HEIGHT: 0px" alt="" src="http://test.mydomain.com/project433q325/track/Images/signature.gif?id=446&etc=1586624376">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end