#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?a)^(?!(?:(?:(?!\n)[\W\d_])*[^\W\d_]){2})(?!(?:[^\d\n]*\d){2})(?!(?:[^!@\#$*\n]*[!@\#$*]){2})[\w!@\#$*]{3}$"
Local $sString = "a1!" & @CRLF & _
"4B_" & @CRLF & _
"*x7" & @CRLF & _
"" & @CRLF & _
"fails" & @CRLF & _
"ab!" & @CRLF & _
"BBB" & @CRLF & _
"*x_" & @CRLF & _
"a1!B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")