import Foundation
let pattern = ##"(?a)^(?!(?:(?:(?!\n)[\W\d_])*[^\W\d_]){2})(?!(?:[^\d\n]*\d){2})(?!(?:[^!@\#$*\n]*[!@\#$*]){2})[\w!@\#$*]{3}$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a1!
4B_
*x7
fails
ab!
BBB
*x_
a1!B
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)