$re = '/(?a)^(?!(?:(?:(?!\n)[\W\d_])*[^\W\d_]){2})(?!(?:[^\d\n]*\d){2})(?!(?:[^!@\#$*\n]*[!@\#$*]){2})[\w!@\#$*]{3}$/m';
$str = 'a1!
4B_
*x7
fails
ab!
BBB
*x_
a1!B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);