import re
regex = re.compile(r"(?a)^(?!(?:(?:(?!\n)[\W\d_])*[^\W\d_]){2})(?!(?:[^\d\n]*\d){2})(?!(?:[^!@\#$*\n]*[!@\#$*]){2})[\w!@\#$*]{3}$", flags=re.MULTILINE)
test_str = ("a1!\n"
"4B_\n"
"*x7\n\n"
"fails\n"
"ab!\n"
"BBB\n"
"*x_\n"
"a1!B")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")