package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)01(\d{6,})(10(\S{6,})17(\d{6})|17(\d{6})10(\S{6,}))`)
var str = `012900553100156910240909077717270909
0155413760137549172802291025C26T2C
01290055310015691024100909077717270909 #is this what you want?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}