use strict;
my $str = '012900553100156910240909077717270909
0155413760137549172802291025C26T2C
01290055310015691024100909077717270909 #is this what you want?';
my $regex = qr/01(\d{6,})(10(\S{6,})17(\d{6})|17(\d{6})10(\S{6,}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}