$re = '/01(\d{6,})(10(\S{6,})17(\d{6})|17(\d{6})10(\S{6,}))/m';
$str = '012900553100156910240909077717270909
0155413760137549172802291025C26T2C
01290055310015691024100909077717270909 #is this what you want?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);