import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s+([-.a-zA-Z\\s,'À-úÀ-ÿ()?\\/\\d]+?)\\s{2,}([-.a-zA-Z\\s,'À-úÀ-ÿ()?\\/\\d]+?)\\s{2,}(I|PF|MA)\\s{2,}(I|PF|PL|LI|MA|CV|MJ)\\s{2,}(\\w+)\\s{2,}(\\d+,\\d{4})";
final String string = "2236 ARGEMIRO PATROCINIO ARGEMIRO I I UBC 3,8462\n\n"
+ "1150721 ZACHARY F CONDON ZACH CONDON I I FINTAGE 8,3333\n\n"
+ "50300 COMERCIAL FONOGRAFICA RGE LTDA. PF LI ABRAMUS 25,0000";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}