const regex = /(\d+)\s+([-.a-zA-Z\s,'À-úÀ-ÿ()?\/\d]+?)\s{2,}([-.a-zA-Z\s,'À-úÀ-ÿ()?\/\d]+?)\s{2,}(I|PF|MA)\s{2,}(I|PF|PL|LI|MA|CV|MJ)\s{2,}(\w+)\s{2,}(\d+,\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s+([-.a-zA-Z\\s,\'À-úÀ-ÿ()?\\\/\\d]+?)\\s{2,}([-.a-zA-Z\\s,\'À-úÀ-ÿ()?\\\/\\d]+?)\\s{2,}(I|PF|MA)\\s{2,}(I|PF|PL|LI|MA|CV|MJ)\\s{2,}(\\w+)\\s{2,}(\\d+,\\d{4})', 'g')
const str = `2236 ARGEMIRO PATROCINIO ARGEMIRO I I UBC 3,8462
1150721 ZACHARY F CONDON ZACH CONDON I I FINTAGE 8,3333
50300 COMERCIAL FONOGRAFICA RGE LTDA. PF LI ABRAMUS 25,0000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);