#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)p|[^e]n$"
Local $sString = "red" & @CRLF & _
"orange" & @CRLF & _
"yellow" & @CRLF & _
"green" & @CRLF & _
"blue" & @CRLF & _
"indigo" & @CRLF & _
"violet" & @CRLF & _
"" & @CRLF & _
"purple" & @CRLF & _
"brown" & @CRLF & _
"pink" & @CRLF & _
"cyan" & @CRLF & _
"maroon"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")