re = /p|[^e]n$/m
str = 'red
orange
yellow
green
blue
indigo
violet
purple
brown
pink
cyan
maroon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end