import re
regex = re.compile(r"p|[^e]n$", flags=re.MULTILINE)
test_str = ("red\n"
"orange\n"
"yellow\n"
"green\n"
"blue\n"
"indigo\n"
"violet\n\n"
"purple\n"
"brown\n"
"pink\n"
"cyan\n"
"maroon")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")