const regex = /p|[^e]n$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('p|[^e]n$', 'gm')
const str = `red
orange
yellow
green
blue
indigo
violet
purple
brown
pink
cyan
maroon`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}