import re
regex = re.compile(r"([^abc]*?)(a)|(b)|(c)|(ab)|(ba)|(ac)|(ca)|(bc)|(cb)|(abc)|(acb)|(bac)|(bca)|(cab)|(cba)", flags=re.MULTILINE)
test_str = ("abracadabra\n"
"a b c\n"
"aa bb cc\n"
"ab ac ba bc ca cb\n"
"abc acb bac bca cab cba")
subst = "$1${2:+b}${3:+c}${4:+a}${5:+bc}${6:+cb}${7:+ba}${8:+ab}${9:+ca}${10:+ac}${11:+bca}${12:+bac}${13:+cba}${14:+cab}${15:+abc}${16:+acb}"
result = regex.sub(subst, test_str)
if result:
print(result)