#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu).*/(JANUARY|SEPTEMBER|NOVEMBER)/.*"
Local $sString = "foo/bar/JANUARY/baz" & @CRLF & _
"foo/bar/FEBRUARY/baz" & @CRLF & _
"foo/bar/MARCH/baz" & @CRLF & _
"foo/bar/APRIL/baz" & @CRLF & _
"foo/bar/MAY/baz" & @CRLF & _
"foo/bar/JUNE/baz" & @CRLF & _
"foo/bar/JULY/baz" & @CRLF & _
"foo/bar/AUGUST/baz" & @CRLF & _
"foo/bar/SEPTEMBER/baz" & @CRLF & _
"foo/bar/OCTOBER/baz" & @CRLF & _
"foo/bar/NOVEMBER/baz" & @CRLF & _
"foo/bar/DECEMBER/baz" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")