// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu).*/(JANUARY|SEPTEMBER|NOVEMBER)/.*").unwrap();
let string = "foo/bar/JANUARY/baz
foo/bar/FEBRUARY/baz
foo/bar/MARCH/baz
foo/bar/APRIL/baz
foo/bar/MAY/baz
foo/bar/JUNE/baz
foo/bar/JULY/baz
foo/bar/AUGUST/baz
foo/bar/SEPTEMBER/baz
foo/bar/OCTOBER/baz
foo/bar/NOVEMBER/baz
foo/bar/DECEMBER/baz
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}