const regex = new RegExp('.*/(JANUARY|SEPTEMBER|NOVEMBER)/.*', 'gmu')
const str = `foo/bar/JANUARY/baz
foo/bar/FEBRUARY/baz
foo/bar/MARCH/baz
foo/bar/APRIL/baz
foo/bar/MAY/baz
foo/bar/JUNE/baz
foo/bar/JULY/baz
foo/bar/AUGUST/baz
foo/bar/SEPTEMBER/baz
foo/bar/OCTOBER/baz
foo/bar/NOVEMBER/baz
foo/bar/DECEMBER/baz
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}