import re
regex = re.compile(r".*/(JANUARY|SEPTEMBER|NOVEMBER)/.*", flags=re.MULTILINE | re.UNICODE)
test_str = ("foo/bar/JANUARY/baz\n"
"foo/bar/FEBRUARY/baz\n"
"foo/bar/MARCH/baz\n"
"foo/bar/APRIL/baz\n"
"foo/bar/MAY/baz\n"
"foo/bar/JUNE/baz\n"
"foo/bar/JULY/baz\n"
"foo/bar/AUGUST/baz\n"
"foo/bar/SEPTEMBER/baz\n"
"foo/bar/OCTOBER/baz\n"
"foo/bar/NOVEMBER/baz\n"
"foo/bar/DECEMBER/baz\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")