#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+,)+\d+$"
Local $sString = "1,2,3,495,5" & @CRLF & _
"1,2,3,45," & @CRLF & _
",12,4,2,67" & @CRLF & _
"1,2 3,4,5,6" & @CRLF & _
"1,2,3,49,5" & @CRLF & _
"1234,5555,2,2555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")