use strict;
my $str = '1,2,3,495,5
1,2,3,45,
,12,4,2,67
1,2 3,4,5,6
1,2,3,49,5
1234,5555,2,2555';
my $regex = qr/^(\d+,)+\d+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}