re = /^(\d+,)+\d+$/m
str = '1,2,3,495,5
1,2,3,45,
,12,4,2,67
1,2 3,4,5,6
1,2,3,49,5
1234,5555,2,2555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end