const regex = /[\s\.]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\.]', 'gm')
const str = `La.chambre.des.officiers.2001
The.2nd.2020
The.Song.of.Names.2020`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);