$re = '/[\s\.]/m';
$str = 'La.chambre.des.officiers.2001
The.2nd.2020
The.Song.of.Names.2020';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;