// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\s\.]").unwrap();
let string = "La.chambre.des.officiers.2001
The.2nd.2020
The.Song.of.Names.2020";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}