use strict;
my $str = 'La.chambre.des.officiers.2001
The.2nd.2020
The.Song.of.Names.2020';
my $regex = qr/[\s\.]/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";