#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?\|\s*(.*?)\s*\|.*"
Local $sString = "20198818-119903 | firmware-check | passed : host test-1000 is connected to a test with Version: 333 | |" & @CRLF & _
"20198818-119903 | other-test-123 | passed : host test-1000 is connected to a test with 333:" & @CRLF & _
"20198818-119903 | test4| passed :| host | is connected to a test with 333" & @CRLF & _
"20198818-119903 | something | passed : host test-1000 is connected to a test with Version:"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)