# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?\|\s*(.*?)\s*\|.*"
test_str = ("20198818-119903 | firmware-check | passed : host test-1000 is connected to a test with Version: 333 | |\n"
"20198818-119903 | other-test-123 | passed : host test-1000 is connected to a test with 333:\n"
"20198818-119903 | test4| passed :| host | is connected to a test with 333\n"
"20198818-119903 | something | passed : host test-1000 is connected to a test with Version:")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.