const regex = /.*?\|\s*(.*?)\s*\|.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?\\|\\s*(.*?)\\s*\\|.*', 'gm')
const str = `20198818-119903 | firmware-check | passed : host test-1000 is connected to a test with Version: 333 | |
20198818-119903 | other-test-123 | passed : host test-1000 is connected to a test with 333:
20198818-119903 | test4| passed :| host | is connected to a test with 333
20198818-119903 | something | passed : host test-1000 is connected to a test with Version:`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);