re = /.*?\|\s*(.*?)\s*\|.*/m
str = '20198818-119903 | firmware-check | passed : host test-1000 is connected to a test with Version: 333 | |
20198818-119903 | other-test-123 | passed : host test-1000 is connected to a test with 333:
20198818-119903 | test4| passed :| host | is connected to a test with 333
20198818-119903 | something | passed : host test-1000 is connected to a test with Version:'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result