#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) (['"`]) # capture this quote character" & @CRLF & _
" (?:\\.|(?!\1).)* # any escaped character, or" & @CRLF & _
" # any character that isn't the captured one" & @CRLF & _
" \1 # the captured quote again" & @CRLF & _
" (*SKIP)(*FAIL) # ignore this" & @CRLF & _
" |" & @CRLF & _
" \?\?? # one or two question marks" & @CRLF & _
" |" & @CRLF & _
" ::?\w+ # word characters marked with one or two colons"
Local $sString = "INSERT INTO xyz WHERE " & @CRLF & _
"a=? " & @CRLF & _
"and b="what?"" & @CRLF & _
"and ??="cheese"" & @CRLF & _
"and `col?`='OK'" & @CRLF & _
"and ::col='another'" & @CRLF & _
"and last!=:least" & @CRLF & _
"and b="wha\"t?""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")