using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (['""`]) # capture this quote character
(?:\\.|(?!\1).)* # any escaped character, or
# any character that isn't the captured one
\1 # the captured quote again
(*SKIP)(*FAIL) # ignore this
|
\?\?? # one or two question marks
|
::?\w+ # word characters marked with one or two colons";
string input = @"INSERT INTO xyz WHERE
a=?
and b=""what?""
and ??=""cheese""
and `col?`='OK'
and ::col='another'
and last!=:least
and b=""wha\""t?""";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}