import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (['\"`]) # capture this quote character\n"
+ " (?:\\\\.|(?!\\1).)* # any escaped character, or\n"
+ " # any character that isn't the captured one\n"
+ " \\1 # the captured quote again\n"
+ " (*SKIP)(*FAIL) # ignore this\n"
+ " |\n"
+ " \\?\\?? # one or two question marks\n"
+ " |\n"
+ " ::?\\w+ # word characters marked with one or two colons";
final String string = "INSERT INTO xyz WHERE \n"
+ "a=? \n"
+ "and b=\"what?\"\n"
+ "and ??=\"cheese\"\n"
+ "and `col?`='OK'\n"
+ "and ::col='another'\n"
+ "and last!=:least\n"
+ "and b=\"wha\\\"t?\"";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}