package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` (['"`]) # capture this quote character
(?:\\.|(?!\1).)*+ # any escaped character, or
# any character that isn't the captured one
\1 # the captured quote again
(*SKIP)(*FAIL) # ignore this
|
\?\?? # one or two question marks
|
::?\w+ # word characters marked with one or two colons`)
var str = `INSERT INTO xyz WHERE
a=?
and b="what?"
and ??="cheese"
and \`col?\`='OK'
and ::col='another'
and last!=:least`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}